summaryrefslogtreecommitdiffstats
path: root/tests/ByteBuffer/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/ByteBuffer/CMakeLists.txt')
-rw-r--r--tests/ByteBuffer/CMakeLists.txt8
1 files changed, 2 insertions, 6 deletions
diff --git a/tests/ByteBuffer/CMakeLists.txt b/tests/ByteBuffer/CMakeLists.txt
index 49a3f7f75..12c2f6e3c 100644
--- a/tests/ByteBuffer/CMakeLists.txt
+++ b/tests/ByteBuffer/CMakeLists.txt
@@ -8,23 +8,19 @@ add_definitions(-DTEST_GLOBALS=1)
set (SHARED_SRCS
${CMAKE_SOURCE_DIR}/src/ByteBuffer.cpp
${CMAKE_SOURCE_DIR}/src/OSSupport/StackTrace.cpp
+ ${CMAKE_SOURCE_DIR}/src/OSSupport/WinStackWalker.cpp
)
set (SHARED_HDRS
${CMAKE_SOURCE_DIR}/src/ByteBuffer.h
${CMAKE_SOURCE_DIR}/src/OSSupport/StackTrace.h
+ ${CMAKE_SOURCE_DIR}/src/OSSupport/WinStackWalker.h
)
set (SRCS
ByteBufferTest.cpp
)
-if (MSVC)
- # Add the MSVC-specific LeakFinder / StackTracer sources:
- list (APPEND SHARED_SRCS ${CMAKE_SOURCE_DIR}/src/LeakFinder.cpp ${CMAKE_SOURCE_DIR}/src/StackWalker.cpp)
- list (APPEND SHARED_HDRS ${CMAKE_SOURCE_DIR}/src/LeakFinder.h ${CMAKE_SOURCE_DIR}/src/StackWalker.h)
-endif()
-
source_group("Shared" FILES ${SHARED_SRCS} ${SHARED_HDRS})
source_group("Sources" FILES ${SRCS})
add_executable(ByteBuffer-exe ${SRCS} ${SHARED_SRCS} ${SHARED_HDRS})